当前位置: 澳门新濠3559 > 操作系统 > 正文

想用树莓派连接usb相机拍摄照片,py2exe不同版本

时间:2019-12-21 19:57来源:操作系统
错误产生 安装 CocoaPods 时报错: 安装命令: sudo gem install cocoapods 报错: ERROR: Error installing cocoapods:activesupport requires Ruby version = 2.2.2. 1、下载安装py2exe 根据电脑系统,python版本下载py2

图片 1

错误产生

安装 CocoaPods 时报错:

安装命令:

sudo gem install cocoapods

报错:

ERROR:  Error installing cocoapods:
activesupport requires Ruby version >= 2.2.2.

1、下载安装py2exe

根据电脑系统,python版本下载py2exe,运行

下载地址:py2exe不同版本下载地址

想用树莓派连接usb相机拍摄照片,,今天一开机输入命令就报错。下面是报错内容。在输入这个命令前已经输入了sudomodprobebcm2835-v4l2实在百思不得其解,明明之前成功拍摄了,现在却报错TAT

解决方式

想用树莓派连接usb相机拍摄照片,py2exe不同版本下载地址。2、创建要运行的程序(例如:guest_game.py)

图片 2

确保创建的.py文件能正常运行

安装 rvm

输入命令:

curl -L get.rvm.io | bash -s stable
source ~/.rvm/scripts/rvm

等待安装结束,查看 rvm 版本,输入命令:

rvm -v

若提示找不到命令,那可能是安装失败了,重复上面安装的步骤。
安装成功会输出版本号:

rvm 1.27.0 (latest) by Wayne E. Seguin <wayneeseguin@gmail.com>, Michal Papis <mpapis@gmail.com> [https://rvm.io/]

3、创建setup.py文件

图片 3

(PS:一开始因为没有写清楚文件路径,运行的时候报错了。加上绝对路径之后就正常了)

通过rvm安装新版Ruby

输入命令:

rvm install ruby-2.2

这次等待比较漫长,安装结束后,再次输入命令确定本地 Ruby 版本:

ruby -v

确认之后,继续安装 Cocoapods 吧!

编辑:操作系统 本文来源:想用树莓派连接usb相机拍摄照片,py2exe不同版本

关键词: