当前位置: 澳门新濠3559 > 服务器运维 > 正文

首先我们启动交换机澳门新濠3559:,具有三层路

时间:2019-11-08 22:07来源:服务器运维
思科交换机配置SSH+Telnet+修改名称,思科ssh Hello大家好,我是Lionel,今天我给大家带来思科路由器配置SSH,Telnet和修改交换机名字的教程。 看我下面操作 首先我们启动交换机,看到 

思科交换机配置SSH+Telnet+修改名称,思科ssh

Hello大家好,我是Lionel,今天我给大家带来思科路由器配置SSH,Telnet和修改交换机名字的教程。
看我下面操作
首先我们启动交换机,看到       Switch>
上面的单词(启动过程很慢)
配置SSH
我们依次输入下面的命令,后面有中文注释命令是什么意思,大家可以根据自己需要进行配置。
Switch>en                                             进入特权模式
Switch#conf t                                         进入配置模式
Switch(config)#int vlan 1                             进入vlan 1
Switch(config-if)#ip add 192.168.6.X 255.255.255.0    设置IP和掩码
Switch(config-if)#no shut                             生效
Switch(config-if)#exit                                退出
Switch(config)#ip domain-name cisco.com               设置域
Switch(config)#crypto key generate rsa                配置加密方式为RSA
Switch(config)#aaa new-model                          启用AAA认证
Switch(config)#username admin password admin          设置SSH用户名和密码
Switch(config)#enable secret cisco                    设置特权模式密码
Switch(config)#ip ssh time 60                         设置SSH登录超时时间
Switch(config)#ip ssh authentication 4                设置登录失败尝试次数
Switch(config)#line vty 0 4                           进入Telnet接口配置模式
Switch(config-line)#transport input SSH               在Telnet接口模式下使用SSH认证
Switch(config)#ip ssh version 2                       若要用SSH2,配置SSH的版本号
Switch(config)#end                                    结束
Switch#wr                                             写入保存

到这步我们wr写入保存,完成了SSH的配置,我们在本地配置一个和交换机同一网段的内网IP。访问这个交换机的IP。
软件用PUTTY就可以。

配置Telnet
配置Telnet的目的是为了有些交换机版本低不支持SSH,所以我们要用Telnet连接交换机。
输入以下命令
设置域名:Router (config)# ip domain-name cisco.com
进入Telnet接口配置模式:Router (config)# line vty 0 4 
Router (config-line)# transport input telnet
Router (config-line)# password admin
Router (config-line)# login
Router (config-line)# exit
Router# wr
这样重启我们就可以用Telnet连接了。

设置交换机名称

Switch(config)#hostname 名称
首先我们启动交换机澳门新濠3559:,具有三层路由转发能力的交换机。只需要一条命令就可以修改名称,我们也可以通过别的方式修改,具体看交换机的版本。

以上就是本周带来的教程,想了解更多教程可以关注我们的官网和

Hello大家好,我是Lionel,今天我给大家带来思科路由器配置SSH,Telnet和修改交换机名字的教程。...

Switch(config)#no ip domain-lookup #关闭域名解析

2、密码、登陆等基本配置

本节介绍的内容为cisco路由器或者交换机的基本配置,在目前版本的cisco交换机或路由器上的这些命令是通用的。本教程用的是cisco的模拟器做的介绍,一些具体的端口显示或许与你们实际的设备不符,但这并不影响基本配置命令的执行。

Cisco 3640 (R4700) processor (revision 0xFF) with 124928K/6144K bytes of memory.

Processor board ID 00000000

R4700 CPU at 100MHz, Implementation 33, Rev 1.2

2 Ethernet interfaces

8 Serial interfaces

DRAM configuration is 64 bits wide with parity enabled.

125K bytes of NVRAM.

8192K bytes of processor board System flash (Read/Write)

         --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]: n  

 

# 此处我们选择no,不进入他的初始化配置向导

 

Press RETURN to get started!      

# 选择no以后,提示你按回车键开始,此处我们需要按回车键

 

*Mar  1 00:43:56.591: %IP-5-WEBINST_KILL: Terminating DNS process

*Mar  1 00:43:58.379: %SYS-5-RESTART: System restarted --

Cisco IOS Software, 3600 Software (C3640-JK9O3S-M), Version 12.3(14)T7, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2006 by Cisco Systems, Inc.

Compiled Wed 22-Mar-06 21:46 by pwade

*Mar  1 00:43:58.411: %SNMP-5-COLDSTART: SNMP agent on host Router is undergoing a cold start

 

Router>         

# 等显示稳定后,出现最初的提示符,注意提示符是“>”,目前所处的状态称为用户模式。

Router>

Router>en     

# 如果在当前状态下没有重复的命令,我们可以用“TAB”键来补齐这条命令,主要目的是为了便于阅读

Router>enable      

# 从用户模式(user mode)进入到特权模式(exec mode),注意提示符的变化,提示符变为“#”

Router#conf t 

Router#configure terminal

(说明:#在特权模式下输入configure terminal进入全局配置模式(global configuration mode),在这之下输入的命令叫做全局命令,一旦输入,将对整个router产生即时影响。如下,注意提示符的变化:)

Router(config)#exit                     # 请注意提示符发生了改变,当前的模式据叫做全局配置模式。

Router#conf

*Mar  1 00:44:26.491: %SYS-5-CONFIG_I: Configured from console by console t      # 在输入命令的过程中,IOS会出现一些即时提示。

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#exit                     # 退出当前的全局配置模式的命令是exit

Router#conf t                       # 重新进入到全局配置模式

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#

*Mar  1 00:44:35.591: %SYS-5-CONFIG_I: Configured from console by consolehos   

# 这行是路由器(交换机)出现的一些即时提示。

Router(config)#hostname test      

# 这条命令用来更改当前设备的名字(名字中可包含设备的楼层、用途等信息),主要是为了将来便于区分设备。

test(config)#                

# 回车后我们就会发现,但前的设备的名字已经发生了改变,变成了test了。

test(config)#enable pass

# 这条命令用来配置设备的登陆密码,用tab键补齐后,再下一行显示完整命令。

test(config)#enable password cisco      # 我们输入这台设备的登陆密码为 cisco

test(config)#end                                 # 我们退回到全局配置模式,校验一下刚才输入的密码

test#sh r 

# 此命令的完整写法是show running-start,此处的sh r用的是省略的写法,因无其他重复的命令所以可以被执行。

Building configuration...
Current configuration : 1559 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname test                # 注意此处显示的是我们配置的设备的名字
!
boot-start-marker
boot-end-marker
!
enable password cisco          
# 此处显示的是刚才我们配置的enable密码,注意此时是用明文显示的,有点不安全。
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!

# 到这一行其实并未全部显示完配置的内容,我们可以按键盘上的任意键来终止继续显示。在显示的过程中通过按回车键可以逐行显示,按空格键可以一页一页的显示。这些操作可在实际的设备中体会。

 

test#conf t                                                       # 重新进入到全局配置模式

 

test(config)#service pass

test(config)#service password-encryption           # 利用这条命令给密码加密显示。

test(config)#end

test#sh r                                                          # 退出到全局配置模式后,验证刚才的配置。

Building configuration...

 

Current configuration : 1565 bytes
!
version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption
!
hostname test
!
boot-start-marker
boot-end-marker
!
enable password 7 070C285F4D06      

# 注意此处刚才明文显示的密码已经变成加密显示了,这样从一定程度上保证了密码的安全。
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
# 验证完毕后按任何一个键中断显示,下面的内容说明终端登陆密码的配置。

 

test#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

test(config)#no service password-encryption

# 可利用这条命令(前面加no)来去掉密码加密功能,cisco的所有命令都可以通过这种方式来禁止。

test(config)#line con

test(config)#line console 0            # 利用这条命令来配置用超级终端登陆时的一些参数。

test(config-line)#pass

test(config-line)#password cisco    # 添加密码,此处我们配置的密码为cisco

test(config-line)#loggi

test(config-line)#logging ?          

# 在任何情况下如果你忘记了命令的相关参数可以用?来获得提示和帮助

synchronous  Synchronized message output

test(config-line)#logging sy

test(config-line)#logging synchronous

# 在我们进行配置时,IOS会产生一些即时的提示信息,而这些信息会冲乱我们的光标显示,用这条命令可以将光标规矩在下一行,即使出现了一些即时的提示。

test(config-line)#exit                   # 退出当前console口的参数配置

test(config)#line vt?                     #  telnet登陆时相关参数的配置,此处用了?来寻求提示。

 

 <0-134>  First Line number

  aux      Auxiliary line

  console  Primary terminal line

  tty      Terminal controller

  vty      Virtual terminal

  x/y      Slot/Port for Modems

test(config)#line vty 0 4       

# 我们配置虚拟终端的0到4,也就是同时允许5个用户可以telnet到这台设备上来。

test(config-line)#pass

test(config-line)#password cisco   

# 我们配置telnet时的密码为cisco,如果此处我们不设置密码,那么用telnet来登陆的时候并不会以空密码登陆,而是会给你提示说:相关密码没有设置,禁止登陆。所以我们为了能远程telnet到这台设备,此处的密码一定要设置好。

test(config-line)#login                 # 这条命令是允许通过telnet来登录

test(config-line)#exit                   # 退出当前配置模式到全局配置模式。

test(config)#

test(config)#

test#conf s            

# 我们在做配置的时候,会出现输入错误的情况,在这种情况下ios会以为你输入的是一个域名

Translating "s"...domain server (255.255.255.255)     

# 那么ios会做长时间的搜寻,试图找到这个域名对应的ip地址.......

Translating "s"...domain server (255.255.255.255)     

# 这段时间是比较长的,那么我们如何禁用它的这个功能呢?

% Unknown command or computer name, or unable to find computer address

test#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

test(config)#no ip domain-lookup        # 在全局配置模式下,将ip域名的搜寻功能关闭就可以了。

test(config)#end

test#conf

*Mar  1 01:40:46.895: %SYS-5-CONFIG_I: Configured from console by console

test#conf x             # 将上述功能关闭以后,再有输入错误的情况会直接提示你输入错误。

        ^

% Invalid input detected at '^' marker.

 test#

test(config)#ip domain-name 202.102.128.68

# 如果有必要将设备配置上DNS功能的话就用这条命令。

 ### 基本配置完毕后我们验证一下所有的配置###

test#sh run

Building configuration...
Current configuration : 1693 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption                # 密码加密显示功能打开
!
hostname test
!
boot-start-marker
boot-end-marker
!
enable password 7 070C285F4D06       # 密码被加密显示了
!
no aaa new-model
!
resource policy
!
memory-size iomem 5

ip subnet-zero
!
!
ip cef   

no ip domain lookup                           # 关闭了域名查找功能

no ip dhcp use vrf connected

!
!
no ip ips deny-action ips-interface

!

no ftp-server write-enable

!

no crypto isakmp ccm
!
(略……)

ip http server

no ip http secure-server

ip classless

!        
control-plane
!
line con 0

 exec-timeout 0 0
 password 7 094F471A1A0A       # 用超级终端登陆的密码,也同样被加密显示
 logging synchronous
line aux 0
line vty 0 4
 password 7 00071A150754         # 用telnet登陆的密码,也同样被加密显示
 login
!
!
end

3、cisco设备端口配置详解

 

User Access Verification

# 从dos提示符下运行telnet ip地址,就会连接到相应的交换机或者路由器

 

Password:                     # 输入配置号的telnet密码,也就是上节提到的vtp中的密码

test>en                       # 进入特权模式

Password:                    # 输入特权模式密码,也就是上节提到的enable密码。注意这些密码在输入的时候屏幕是不显示的。

test#

test#

test#sh ip int brief         # 查看当前所有端口状态,包括vlan和实际的物理接口状态

 

Interface              IP-Address      OK? Method Status                Protocol 

# 这行列示的各种状态的名称

FastEthernet1            unassigned      YES NVRAM  down                  down   

Vlan1                  192.168.113.254  YES NVRAM  up                    up

# vlan1的状态是active    

Vlan2                  172.16.0.2       YES NVRAM  up                    up     

Vlan10                 192.168.101.254  YES NVRAM  up                    up     

Vlan20                 192.168.102.254  YES NVRAM  up                    up     

Vlan30                 192.168.103.254  YES NVRAM  up                    up     

Vlan40                 192.168.104.254  YES NVRAM  up                    up     

Vlan50                 192.168.105.254  YES NVRAM  up                    up     

Vlan60                 192.168.106.254  YES NVRAM  up                    up     

Vlan70                 192.168.107.254  YES NVRAM  up                    up     

Vlan80                 192.168.108.254  YES NVRAM  up                    up     

Vlan100                192.168.110.254  YES NVRAM  up                    up     

Vlan110                192.168.111.254  YES NVRAM  up                    up     

Vlan120                192.168.112.254  YES NVRAM  up                    up     

Vlan150                192.168.100.254  YES NVRAM  up                    up     

Vlan160                192.168.115.254  YES NVRAM  up                    up     

GigabitEthernet1/1        unassigned      YES unset     up                    up

 

# 物理接口gi1/1也是active状态    

GigabitEthernet1/2     unassigned      YES unset  down                  down   

GigabitEthernet1/3     unassigned      YES unset  down                  down   

GigabitEthernet1/4     unassigned      YES unset  down                  down   

GigabitEthernet1/5     unassigned      YES unset  down                  down   

GigabitEthernet1/6     unassigned      YES unset  down                  down   

GigabitEthernet1/7     unassigned      YES unset  down                  down    

GigabitEthernet1/8     unassigned      YES unset  down                  down   

GigabitEthernet1/9     unassigned      YES unset  down                  down   

 

# 说明:通过上述命令即可以查看当前设备所有状态的情况也可以查看端口的表示方式。在此例中我们登陆的是一台cisco4503的三层交换机;其中GigabitEthernet1/1,表示的是这台交换机上的第1块业务板的第1个端口,并且此端口是个千兆端口;而GigabitEthernet3/19表示的是这台交换机上的第3块业务版的第19个端口,并且此端口也是一个千兆端口,其他的端口以此类推。千兆端口的名称为:GigabitEthernet,百兆端口的名称为:FastEthernet。

 

test# conf t    

# 进入到全局配置模式。要想对端口、vlan、路由等操作一定要到全局配置模式中来。

Enter configuration commands, one per line.  End with CNTL/Z.

test(config)#inter

test(config)#interface gi1/2          

# 通过此命令可进去端口配置模式,此处我们进入的是GigabitEthernet1/2口,gi1/2为简写。

test(config-if)#?                  

#回车后进入到端口配置模式,注意提示符的变化,输入?寻求在这个模式着那个的帮助。

Interface configuration commands:

  access-group            Access group configuration

  arp                     Set arp type (arpa, probe, snap) or timeout

  auto                    Configure Automation

  backup                  Modify backup parameters

  bandwidth               Set bandwidth informational parameter

  bgp-policy              Apply policy propogated by bgp community string

  carrier-delay           Specify delay for interface transitions

  cdp                     CDP interface subcommands

  channel-group           Etherchannel/port bundling configuration

  channel-protocol        Select the channel protocol (LACP, PAgP)

  dampening               Enable event dampening

  default                 Set a command to its defaults

  delay                   Specify interface throughput delay

  description             Interface specific description

  dot1x                   Interface Config Commands for 802.1x

  duplex                  Configure duplex operation.

  exit                    Exit from interface configuration mode

  flow-sampler            Attach flow sampler to the interface

  flowcontrol             Configure flow operation.

  help                    Description of the interactive help system

  ip                      Interface Internet Protocol config commands

  isis                    IS-IS commands

  iso-igrp                ISO-IGRP interface subcommands

  keepalive               Enable keepalive

  l2protocol-tunnel       Tunnel Layer2 protocols

  lacp                    LACP interface subcommands

  load-interval           Specify interval for load calculation for an interface

  logging                 Configure logging for interface

  loopback                Configure internal loopback on an interface

  mac                     MAC interface commands

  macro                   Command macro

  max-reserved-bandwidth  Maximum Reservable Bandwidth on an Interface

  mtu                     Set the interface Maximum Transmission Unit (MTU)

  no                      Negate a command or set its defaults

  pagp                    PAgP interface subcommands

  power                   Power configuration

  qos                     QoS configuration

  rmon                    Configure Remote Monitoring on an interface

  service-policy          Configure QoS Service Policy

  shutdown                Shutdown the selected interface

  snmp                    Modify SNMP interface parameters

  spanning-tree           Spanning Tree Subsystem

  speed                   Configure speed operation.

  storm-control           storm configuration

  switchport              Set switching mode characteristics

  timeout                 Define timeout values for this interface

  transmit-interface      Assign a transmit interface to a receive-only interface

  tx-queue                Configure interface transmit queue

  udld                    Configure UDLD enabled or disabled and ignore global UDLD setting

  vlan-range              config vlan

 

 

test(config-if)#spe

test(config-if)#speed ? 

# 我们可指定这个端口的速度,比如这个端口接的是一个百兆的收发器,我们就可以强制将此端口设置成100M

  10    Force 10 Mbps operation                     # 强制此端口为10M

  100   Force 100 Mbps operation                   # 强制此端口为100M

  1000  Force 1000 Mbps operation                 # 强制此端口为1000M      

  auto  Enable AUTO speed configuration        # 允许速度自动协商

 

test(config-if)#speed 100      

# 通过此命令就可将此端口强制设成100M,默认的状态下是auto。

test(config-if)#dup

test(config-if)#duplex ?  # 用此命令可配置此端口的双工模式,有3个选项供选择。

  auto  Enable AUTO duplex configuration       # 自动配置此端口的双工模式

  full  Force full duplex operation                   # 强制此端口为全双工模式

  half  Force half-duplex operation                  # 强制此端口为半双工模式

 

test(config-if)#duplex auto

test(config-if)#end         # 用end命令可直接退回到特权模式,用exit是一层一层的退出。

test#ter

test#terminal moni

test#terminal monitor   

# 打开终端监控。当用telnet登陆的时候默认是不显示各端口的实时变化情况的,打开这个功能就能实时的看到这台交换机上哪个端口up,哪个端口down,这对于排错的时候是很有帮助的。

test#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

test(config)#int gi1/2     # 重新回到端口配置模式

test(config-if)#shut        # 此命令可手工关闭此端口

test(config-if)#no shut   # 此命令为打开此端口

test(config-if)#switchport access vlan ? 

# 这条命令可配置此端口属于哪个vlan,当然此vlan要事先建好。

  <1-4094>  VLAN ID of the VLAN when this port is in access mode

  dynamic   When in access mode, this interfaces VLAN is controlled by VMPS

 

test(config-if)#switchport access vlan 100   

# 我们配置此端口属于vlan100,如果此端口事先属于其他vlan那么,会从其他vlan退出

test(config-if)#exit

test(config)#int rang                    # 亦可成批的配置端口,利用这个命令

test(config)#int range gi 1/1 - 5   

# 表示同时对gi1/1到gi1/5这5个端口进行操作,注意命令“1 - 5”,之间有空格。

 

test(config-if-range)#switchport access vlan 100         # 可同时配置这5个端口属于vlan100

test(config-if-range)#shutdown                                 # 可同时关闭这5个端口

test(config-if-range)#no shutdown                             # 可同时启用这5个端口

test(config-if-range)#exit

test(config-if)#end

test#

test#sh int gi1/2                                                       # 在特权模式中,可查看单个端口的状态

GigabitEthernet1/2 is down, line protocol is down (notconnect)

# 这行说明此端口当前的状态是down的

  Hardware is GigabitEthernetPort, address is 001a.6db4.a3c1 (bia 001a.6db4.a3c1)   

# 此端口的MAC地址

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Auto-duplex, Auto-speed, link type is auto, media type is 10/100/1000-TX         

# 此端口的模式为10/100/1000-TX

  input flow-control is off, output flow-control is off

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 multicast)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 input packets with dribble condition detected

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

test#sh int gi1/1

GigabitEthernet1/1 is up, line protocol is up (connected)   

# 这行表明此端口是up的,并且连有网线。

  Hardware is GigabitEthernetPort, address is 001a.6db4.a3c0 (bia 001a.6db4.a3c0)

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, link type is auto, media type is 10/100/1000-TX

  input flow-control is off, output flow-control is off

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 1293000 bits/sec, 426 packets/sec

  5 minute output rate 2410000 bits/sec, 528 packets/sec

     273591244 packets input, 142285545179 bytes, 0 no buffer

     Received 0 broadcasts (0 multicast)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored       # 没有输入错误,表明链路状态良好

     0 input packets with dribble condition detected

     335026620 packets output, 223732323465 bytes, 0 underruns  # 输出数据包统计

     0 output errors, 0 collisions, 0 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

test#wr           # 保存刚才的配置结果

 

5:配置使能密码(加密)enable secret ciscolab 以cicsolab 为例

R1(config-if)#no shutdown #进入fa0/1端口

1、基本概念介绍

       IOS:       互联网操作系统,也就是交换机和路由器中用的操作系统

       VLAN:    虚拟lan

       VTP:       VLAN TRUNK PROTOCOL

       DHCP:    动态主机配置协议

       ACL:    访问控制列表

       三层交换机:具有三层路由转发能力的交换机

本教程中“#”后的蓝色文字为注释内容。

 

swich(conf-if)#no shut

1、配置PC0

cisco(config)#ip domain-name test

SW1(config)#line vty 0 4#进入虚拟终端

拔下交换机电源线。

SW1(config)#ip default-gateway 192.168.1.254 #设置该交换机的默认网关

9:交换机恢复出厂默认恢复命令

3、配置R1路由器

 

R1(config-if)#ip address 192.168.1.254 255.255.255.0 #配置fa0/0的IPD地址为192.168.1.254,子网掩码为255.255.255.0

8:查看命令show

Interface              IP-Address      OK? Method Status                Protocol

 

SW1(config-if)#ip address 192.168.1.1 255.255.255.0 #配置交换机的管理地址为192.168.1.1子网掩码为255.255.255.0

swich(conf-line)#login

4、配置PC1

swich(conf)#interface vlan 1 以vlan 1端口作为远程登录的接口,其他端口亦可

FastEthernet0/0        192.168.1.254   YES manual up                    up

把“config.old”文件改名为“config.text”: switch: rename flash: config.old flash: config.text

2、配置SW1交换机

 

SW1(config-line)#login #敲该命令登陆下

running-configure

SW1(config-line)#login local #设置本地用户的telnet登陆

cisco(config)#crypto key generate rsa

R1(config-if)#ip address 192.168.2.254 255.255.255.0 #配置fa0/1的IPD地址为192.168.2.254,子网掩码为255.255.255.0

switch(conf)# ip address 192.168.1.1 255.255.255.0 配置交换机端口ip 和子网掩码

R1(config-line)#exec-timeout 0 0

把“config.text”文件改名为“config.old”: switch: rename flash: config.text flash: config.old

SW1(config)#line vty 0 4 #进入虚拟终端

switch> enable

拓扑图如下:

2:进入全局配置模式configure terminal

澳门新濠3559 1

d.将vty线路下的登录方式改为 ssh

SW1(config-line)#password ccna5188$ #设置telnet密码为ccna5188$

7:进入交换机某一端口interface fastehernet 0/17 以17 端口为例

SW1(config)#int vlan1 #进入vlan1的端口

switch(conf)#hostname cisco001

FastEthernet0/1        192.168.2.254   YES manual up                    up

4:配置使能口令(未加密)enable password cisco 以cisco 为例

澳门新濠3559 2

show mac-address-table 查看mac 地址表

Vlan1                  unassigned      YES unset  administratively down down

cisco001(conf)# enable password cisco

R1#show ip int brief

switch> enable

Switch(config-line)#exec-timeout 0 0 #与交换机保持连接的时延,这里的设置是与路由器永远保持连接,除非自己logout

 

R1(config-line)#logging syn

switch> enable

R1(config-if)#no shutdown #打开端口

swich(conf-if)#ip address 192.168.1.1 255.255.255.0

SW1(config)#username ccna password ccna5188$ #设置本地用户ccna,密码为ccna5188$

10:交换机的密码恢复

R1(config)#no ip domain-lo 

show running-configure 查看交换机当前起作用的配置信息

配置交换机远程管理地址和默认网关

查看flash 中的文件: switch: dir flash:

5、在路由器上查看端口的状态

% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]

SW1(config-if)#no shutdown #启动这个vlan1

 

R1(config)#int fa0/0 #进入fa0/0端口

show interface vlan 1 查看交换机有关ip 协议的配置信息

澳门新濠3559 3

switch (conf-if)#no shut 激活端口

Switch(config-line)#logging syn #设置模式同步

switch#configure terminal

6、测试PC1远程管理SW1

进入特权模式察看flash 里的文件: show flash :

Switch(config)#hostname SW1 #修改交换机的名称为SW1

 

Router(config)#hostname R1

switch(conf)# interface vlan 1

R1(config-if)#no shutdown #打开端口

1:进入特权模式enable

SW1(config)#enable secret ccnp@5188 #设置特权模式的登陆密码(密文)

swich(conf)line vty 0 4 设置0-4 个用户可以telnet 远程登陆

澳门新濠3559 4

switch (conf-if)#exit

switch(conf)# enable secret ciscolab

switch(conf)#

在switch:后执行flash_ini 命令:switch: flash_ini

switch (conf)#ip default-gateway 192.168.254 设置网关地址

cisco001(conf)#

show interface fastethernet 0/1 察看交换机1 接口具体配置和统计信息

switch> enable

swich(conf-if)#exit

 

cisco(config)#line vty 0 4

 

 b.配置域名:

switch#configure terminal

switch#c onfigure terminal

switch# erase startup-configure

swich(conf)#enable password cisco 以cisco 为特权模式密码

12.交换机ssh远程登录设置:

switch# show version 察看系统中的所有版本信息

switch> enable

switch> enable

switch#configure terminal

说明:VTP(VLAN Trunking Protocol):是VLAN中继协议,它是思科私有协议。作用是同步各个交换机之间的VLAN信息。

cisco(config-line)#transport in ssh

6:设置虚拟局域网vlan 1 interface vlan 1

 

switch> enable

3:交换机命名hostname name 以cisco001 为例

重新设置密码并保存。

c.指定加密长度:

用手按着交换机的MODE 键,插上电源线

 

 a.设定一个非默认的hostname

执行boot: switch: boot

switch(conf-if)#

switch# reload

把“ config.text ” 拷入系统的“ running-configure ”: copy flash: config.text system :

swich(conf-line)#password 123456

Switch(config)#hostname cisco

 

switch#configure terminal

switch#

13.配置vtp同步

switch> 用户模式

交换机进入是否进入配置的对话,执行no :

switch> enable

How many bits in the modulus [512]: 1024

 

switch#configure terminal

switch> enable

11.交换机telnet 远程登录设置:

switch>en

switch(conf)# interface fastehernet 0/17

switch#configure terminal

编辑:服务器运维 本文来源:首先我们启动交换机澳门新濠3559:,具有三层路

关键词: