当前位置: 澳门新濠3559 > 服务器运维 > 正文

1.安装u盘制作工具unetbootin,需要安装fctix.重启

时间:2019-11-09 19:36来源:服务器运维
ubuntu作为开发机准备,ubuntu开发机准备 我的硬件环境:固态系统盘60G,机械盘320 一、温度监控 sudo apt-get install lm-sensors hddtempsudo sensors-detect 开始检测硬件传感器sensors 查看,确保已经工

ubuntu作为开发机准备,ubuntu开发机准备

我的硬件环境:固态系统盘60G,机械盘320

一、温度监控

sudo apt-get install lm-sensors hddtempsudo sensors-detect 开始检测硬件传感器sensors  查看,确保已经工作
sudo apt-get install psensor 
----------------------------------------------------------------------二、导航条显示上下行网速,u和内存占用
sudo add-apt-repository ppa:fossfreedom/indicator-sysmonitor

sudo apt-get update 

sudo apt-get install indicator-sysmonitor
``````````````

----------------------------------------------------------------------三、截屏软件sudo add-apt-repository ppa:shutter/ppa 添加安装包软件源

sudo apt-get update 更新源
sudo apt-get install shutter 
----------------------------------------------------------------------
参考:http://zwkufo.blog.163.com/blog/static/258825120141283942244/
http://idea.lanyus.com/ sudo mkfs -t ext4 /dev/sdb

打开Setting>Keyboards 设置快捷方式

四、即时通讯

apt-get install pidgin

五、制作U盘启动盘

1.安装u盘制作工具unetbootin
sudo apt-get install unetbootin
2.格式化u盘
sudo fdisk -l #查看U盘盘符,假设为/dev/sdb
sudo umount /dev/sdb #先卸载u盘
sudo mkfs.vfat /dev/sdb #格式化为fat32模式
3.使用unetbootin制作u盘镜像

六、ubuntu 16.04 LTS 安装 teamviewer

  64位Ubuntu 16.04系统需要添加32位架构支持,命令如下。 sudo dpkg --add-architecture i386 sudo apt-get update 现在,安装TeamViewer的依赖包。 sudo apt-get install libdbus-1-3:i386 libasound2:i386 libexpat1:i386 libfontconfig1:i386 libfreetype6:i386 libjpeg62:i386 libpng12-0:i386 libsm6:i386 libxdamage1:i386 libxext6:i386 libxfixes3:i386 libxinerama1:i386 libxrandr2:i386 libxrender1:i386 libxtst6:i386 zlib1g:i386 libc6:i386 再安装TeamViewer。 wget sudo dpkg -i teamviewer_i386.deb 安装完成后就能从Unity的Dash菜单里启动TeamViewer了。


1.挂载机械盘

永久性挂载分区的办法是修改分区文件/etc/fstab

查看硬盘状态:

vim /etc/fstab

sudo blkid /dev/sdb1   得到到/dev/sdb1这个分区的UUID

磁盘>编辑挂载选项

最终fstab显示:

Ubuntu 离线安装Mysql,ubuntu离线mysql

一、安装包

      先从网络上,下载Mysql安装包,复制到U盘

      下载地址:

二、挂载U盘

     2.1查看分区

   先输入命令  cat  /proc/partitions

   插入U盘,重新输入命令

         cat  /proc/partitions

        结果发现多了

         8       16    *** sdb
         8       17    *** sdb1

         图片 1

   新插入的U盘就是/dev/sdb1

       2.2 文件系统格式

    检查U盘的文件系统格式,输入命令

          sudo  fdisk -l /dev/sdb

       2.3 挂载U盘

   以media/usb为挂载点,检查/media/usb是否存在,若不存在则创建文件夹 sudo mkdir usb,确认目录存在再输入:

        sudo mount  -t  vfat  /dev/sdb1  /media/usb

       2.4卸载

         umount  /media/usb

         注:安装成功,拔出U盘时运行

三、安装Mysql

    3.1 解压安装包

            tar -xvf mysql-server_5.6.37-1ubuntu14.04_amd64.deb-bundle.tar

    3.2 增加执行权限

       chmod  +x  *.deb

    3.3 安装

  3.3.1  安装依赖包

    sudo dpkg –i  libaio1_0.3.110-2_amd64.deb

  3.3.2  按顺序安装mysql

    sudo dpkg -i mysql-common_5.6.37-1ubuntu14.04_amd64.deb

    sudo dpkg -i mysql-community-server_5.6.37-1ubuntu14.04_amd64.deb

    sudo dpkg -i  libmysqlclient18_5.6.37-1ubuntu14.04_amd64.deb

    sudo dpkg -i   libmysqlclient-dev_5.6.37-1ubuntu14.04_amd64.deb

    sudo dpkg –i  libmysqld-dev_5.6.37-1ubuntu14.04_amd64.deb

    sudo dpkg –i   mysql-community-client_5.6.37-1ubuntu14.04_amd64.deb

    sudo dpkg –i  mysql-client_5.6.37-1ubuntu14.04_amd64.deb

    sudo dpkg –i  mysql-common_5.6.37-1ubuntu14.04_amd64.deb

    sudo dpkg –i  mysql-community-server_5.6.37-1ubuntu14.04_amd64.deb

      弹出root密码输入框:

    sudo dpkg –i  mysql-server_5.6.37-1ubuntu14.04_amd64.deb

 3.4 执行数据库脚本(可选项,导入业务初始化数据)

    3.4.1 登录mysql  mysql –uroot –p

    3.4.2 创建数据库   create   database  erp;

    3.4.3 使用创建的数据库  use erp;

    3.4.4 执行sql脚本文件  source /home/orm/mysql.sql;

   

离线安装Mysql,ubuntu离线mysql 一、安装包 先从网络上,下载Mysql安装包,复制到U盘 下载地址: 二、挂载...

分享Ubuntu下命令行方安装TeamViewer的过程,供参考,希望对大家有所帮助。

  1. 安装ssh服务:

第一步: 下载 安装包

先安装sudo apt-get install openssh-server

从官网下载ubuntu的deb安装包 下载链接: 应该是外网下载比较慢  耐心等待

后安装sudo apt-get install openssh-client

第二步: 执行命令

 显示sshd则表示服务安装成功

## 不加sudo 会提示照片中的错误:dpkg:error:requestd operation requires superuser privilege
## teamviewer_12.0.71510_i386.deb 为下载的安装包名称
>> sudo dpkg -i teamviewer_12.0.71510_i386.deb
 
dpkg: error processing package teamviewer:i386 (--install):
 dependency problems - leaving unconfigured
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Errors were encountered while processing:
 teamviewer:i386
 
##报错原因:这是由于我的ubuntu系统是64位的,必须添加32位的架构。

sain@Linux ~/Desktop $ ps -A | grep ssh*
1214 ? 00:00:00 cinnamon-sessio
1276 ? 00:00:00 ssh-agent
5389 ? 00:00:00 sshd

第三步:添加32位架构

 

>> sudo dpkg --add-architecture i386
>> sudo apt-get update
## 在缺少依赖包的安装 需要执行:sudo apt-get -f install
>> sudo apt-get -f install

  1. sougou输入法,网易云音乐,wps,visualstudiocode

第四步:执行安装命令

## 执行安装程序命令:sudo dpkg -i teamviewer_11.0.xxxxx_i386.deb
>> sudo dpkg -i teamviewer_12.0.71510_i386.deb
## 出现 Processing xxxx表示安装成功

第五步:接受license

    5.1 停止teamview

## 停止服务。执行命令
>> sudo teamviewer --daemon stop

安装完sogoupinyin_2.2.0.0102_amd64.deb之后,需要安装fctix.重启

    5.2 修改配置文件

应用程序中搜素fcitx configuration,添加搜狗输入法

## 在文件/opt/teamviewer/config/global.conf末尾增加以下内容(由于只读限制,所以可能需要用到管理员权限)
## [int32] EulaAccepted = 1
## [int32] EulaAcceptedRevision = 6
>> cd /opt/teamviewer/config/
>> ll
>> vim global.conf
## 添加一下内容
## [int32] EulaAccepted = 1
## [int32] EulaAcceptedRevision = 6
## 保存退出
>> wq
## 为了一次成功,修改文件后最好是查看一下修改的文件
>> cat global.conf
## 确认添加保存了之后启动teamviewer

 

    5.3 启动teamviewer

  1. 安装shadowsocks

## 启动teamviewer
>> sudo teamviewer --daemon start

通过PPA源安装,仅支持Ubuntu 14.04或更高版本。

第六步:获取Teamviewer ID

打开终端

## 获取teamviewer ID
>> teamviewer --info print id

sudo add-apt-repository ppa:hzwhuang/ss-qt5

第七步:设置密码

sudo apt-get update

## 设置teamviewer 密码
>> sudo teamviewer --passwd [NEWPASSWORD]

sudo apt-get install shadowsocks-qt5

到此,恭喜你已经安装成功,可以用Windows 测试

 4.安装Guake Terminal和sublime

备注:
    在接受license的步骤存在一个坑,在安装TeamViewer的时候,认为你是以界面形式安装的,所以,会弹出一个对话框,提醒你接受license,但是,由于你用ssh登录的,所以,这个对话框你看不到,自然也不会去接受协议,从而导致在使用时连接失败。

sudo apt-get install guake

Ubuntu 15.10中如何安装TeamViewer 11  http://www.linuxidc.com/Linux/2015-12/126689.htm

另外可参考

更多Ubuntu相关信息见Ubuntu 专题页面 http://www.linuxidc.com/topicnews.aspx?tid=2

sublime安装参考:

本文永久更新链接地址:http://www.linuxidc.com/Linux/2017-12/149279.htm

1.下载sublime text3 deb包
wget https://download.sublimetext.com/sublime-text_build-3103_amd64.deb
2.安装sublime text3
sudo dpkg -i sublime-text_build-3103_amd64.de

图片 2

 

 5. AndroidStudio 配置

归一化配置:

sdk目录: 

~/Android_tools/sdk

启动快捷方式:(不一定有效)

[Desktop Entry]
Version=1.0
Type=Application
Name=AndroidStudio2.3
Comment=AndroidStudio
Icon=/opt/android-studio/bin/studio.png
Exec=/opt/android-studio/bin/studio.sh
Terminal=false
StartupNotify=tr

 

更好的方法是启动androidstudio,Tools菜单下直接创建

 

  1. deepin root 账号设置

deepin系统默认是没有为root账号设置密码的,需要执行下面的指令 

sudo passwd root

 

7.开机自动挂载分区

编辑系统/etc/fstab 文件,默认是以UUID区分各分区

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda7 during installation
UUID=20c18c6c-7fc0-4c30-bd9f-d5df7095f2da /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda6 during installation
UUID=0ba8d57e-a628-40ad-a106-aa3d56f21ff2 /boot           ext4    defaults        0       2
# /home was on /dev/sda8 during installation
UUID=55b3eb18-13c2-4e34-90f6-4df36bf449fa /home           ext4    defaults        0       2
# swap was on /dev/sda5 during installation
UUID=31ed8d6a-2575-4990-8ee5-0f101eb8b975 none            swap    sw              0       0

查看硬盘信息,可以看到UUID和分区的其实有一一对应关系:

sain@Linux ~/Desktop $ sudo blkid
[sudo] password for sain: 
/dev/sda1: LABEL="ESP" UUID="F46C-A96B" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="af5dc20b-b10b-4391-85b2-05e30732df65"
/dev/sda3: LABEL="OS" UUID="F2369D40369D06AF" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="ca736ee9-c841-49b9-bd67-454d8e6b7c1e"
/dev/sda4: LABEL="Data" UUID="D20C9C1D0C9BFAA5" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="de967f44-f620-4234-b310-6f500384768c"
/dev/sda5: UUID="31ed8d6a-2575-4990-8ee5-0f101eb8b975" TYPE="swap" PARTUUID="e7c24756-5ba1-4155-8242-7acee14a432c"
/dev/sda6: UUID="0ba8d57e-a628-40ad-a106-aa3d56f21ff2" TYPE="ext4" PARTUUID="f898d6c1-8992-495d-9764-a62c1adb3ab1"
/dev/sda7: UUID="20c18c6c-7fc0-4c30-bd9f-d5df7095f2da" TYPE="ext4" PARTUUID="5b45a43d-c981-4f52-adea-53158b5ba79c"
/dev/sda8: UUID="55b3eb18-13c2-4e34-90f6-4df36bf449fa" TYPE="ext4" PARTUUID="89854a0e-f085-498d-852e-1afa819d8675"
/dev/sda9: LABEL="WINRETOOLS" UUID="F6A0BFFCA0BFC203" TYPE="ntfs" PARTUUID="667d7919-0759-4c4b-8b02-51fbc2f380b2"
/dev/sda2: PARTLABEL="Microsoft reserved partition" PARTUUID="97ac0bb1-226a-48b2-8745-343f3827b0d5"

所以,简单起见,挂在某个硬盘

只需要/etc/fstab 在末尾加上一句,保存,重启实现开机自动挂载 

/dev/sda4 /media/sain/Data ntfs defaults 0 0

defaults 等于rw,suid,dev,exec,auto,nouser,async

fstab参数解释

  

安装软件可能出现的问题:

情况1:

E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

说明:

因为安装的时候出现了一点问题,最后apt-get的包依赖关系被我搞乱了

解决办法:

在终端输入:apt-get -f install

然后在输入:

sudo apt-get install flex

情况2:

有的时候,使用sudo apt-get install可能导致意想不到的错误,尤其是中途中断了安装时,错误信息为:
Errors were encountered while processing:
ttf-dustin
khangman
kdeedu
kde
E: Sub-process /usr/bin/dpkg returned an error code (1)
此时可以这样解决:
cd /var/lib/dpkg
sudo mv info info.bak
sudo mkdir info
重新安装,在此为:
sudo apt-get --reinstall install ttf-dustin khangman kdeedu kde

 

推荐的软件,待尝试

 

 

 

Ubuntu增加快捷图标

[Desktop Entry]
Encoding=UTF-8
Name=Android Studio
Comment=android studio
Exec=/opt/android-studio/bin/studio.sh
Icon=/opt/android-studio/bin/bin/studio.png
Terminal=false
StartupNotify=true
Type=Application

 

 

 

win7 远程桌面ubuntu16.04

 

使用win10远程控制ubuntu16.04

使用win10远程控制ubuntu16.04,网上很多需要安装xfce桌面的。今天介绍一下,不需要安装其他桌面,使用Ubuntu16.04自带桌面,漂亮美观。
 
Ubuntu16.04端:
1、打开终端,安装xrdp,vncserver
sudo apt-get install xrdp vnc4server xbase-clients
2、安装desktop sharing(Ubuntu16.04默认已经安装),可以到应用商店下载。打开desktop sharing,设置如下:
3、安装安装dconf-editor,取消权限限制:
sudo apt-get install dconf-editor
dconf-editor设置:org > gnome > desktop > remote-access,取消 “requlre-encryption”
 
Win10端:
搜索远程桌面连接,输入Ubuntu的ip地址,点击连接。
选择vnc-any,输入Ubuntu的ip地址,端口不变(5900),桌面共享设定的密码,即可远程连接到ubuntu 16.04桌面。
 
参考http://www.linuxdiyf.com/linux/27078.html
 
dconf-editor有一定概率启动不了
 
Starting dconf-editor: imediately crashes:

(dconf-editor:15007): GLib-GIO-ERROR **: Settings schema 'ca.desrt.dconf-editor.Settings' is not installed

Trace/breakpoint trap (core dumped)

执行下面:
sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

参考:https://bugzilla.redhat.com/show_bug.cgi?id=1005156

 误删/var/lib/dpkg/info 解决办法

1、手动新建info目录:

mkdir/var/lib/dpkg/info

2、重新刷新软件安装列表

 

sudo apt-get upgrade

sudo apt-get install dis-upgrade

把所有的软件更新

ubuntu samba配置
安装samba

sudo apt get-install samba
启动时碰到一堆问题,结果发现是由于/etc/samba/smb.conf文件不存在
新建该文件

[global]
security = user
guest ok = yes
dos charset = UTF-8
unix charset = UTF-8
display charset = UTF-8
wins support = yes
time server = yes
[home]
comment = public share
path = /home/ninjame/
valid user = ninjame
browseable = yes
writable = no

[aosp]
comment = public share
path = /home/ninjame/aosp
valid user = ninjame
browseable = yes
writable = yes

增加samba密码

sudo  smbpasswd  -a user,新增用户,该用户和ubuntu用户不是一回事,一定要加sudo,否则没有任何提示

重启服务

sudo service smbd restart

 

安装samba过程可能有些过于激进的操作,系统只能进入高级选项,选择一个特定的版本重启,且无法进入正常界面

考虑将系统内核进行升级

参考:

找到想升级的版本:

ninjame@ubuntu1604:~$ uname -sr
Linux 4.4.0-79-generic

wget  http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.52/linux-headers-4.4.52-040452_4.4.52-040452.201702260631_all.deb
wget  http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.52/linux-headers-4.4.52-040452-generic_4.4.52-040452.201702260631_amd64.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.52/linux-image-4.4.52-040452-generic_4.4.52-040452.201702260631_amd64.deb

 4.4.80

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.80/linux-headers-4.4.80-040480_4.4.80-040480.201708062341_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.80/linux-headers-4.4.80-040480-generic_4.4.80-040480.201708062341_amd64.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.80/ linux-image-4.4.80-040480-generic_4.4.80-040480.201708062341_amd64.deb

 

 

以上命令在用户目录~下执行就可以,安装后在/boot 目录生成新文件

下载完成这些所有内核文件后,如下安装:

  1. $ sudo dpkg -i *.deb

图片 3

 

安装完成后,重启并验证新的内核已经被使用了:

  1. $ uname -sr

就是这样。你下次就可以使用比 Ubuntu 16.04 默认安装的内核的更新版本了。

 

编辑:服务器运维 本文来源:1.安装u盘制作工具unetbootin,需要安装fctix.重启

关键词: